加入收藏 | 设为首页 | 会员中心 | 我要投稿 核心网 (https://www.hxwgxz.com/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDoj1047Integer Inquiry(大数连续相加)

发布时间:2021-01-02 09:34:23 所属栏目:大数据 来源:网络整理
导读:Integer Inquiry Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 19438????Accepted Submission(s): 5087 Problem Description One of the first users of BIT's new supercomputer was Chip D

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19438????Accepted Submission(s): 5087


Problem Description One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)
?
Input The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
?
Output Your program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N,then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
?
Sample Input
  
  
   
   1


123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
  
  
?
Sample Output
  
  
   
   370370367037037036703703703670
  
  
 
#include<stdio.h>
#include<string.h>
#define N 1010

void add(int a[],int c[],int len)
{
	int f,ans;
	for(int i = 0;i < len;i ++){
		ans = a[i] + c[i];
		f = ans / 10;
		c[i+1] += f;
		c[i] = ans % 10;
	}
}

int main()
{
	int T,a[N],c[N],i,j,flag=0;
	char str[N];
	scanf("%d",&T);
	for(j = 1;j <= T;j ++){
		memset(a,sizeof(a));
		memset(c,sizeof(c));
		while(~scanf("%s",str)){
			if(str[0]=='0')
				break;
			flag=1;
			int len = strlen(str);
			for(i = 0; i < len;i ++)
				a[i] = str[len-i-1]-'0';
			add(a,c,len);
		}
		if(c[0]==0&&flag==0)
			printf("0n");
		else{
			for(i = N-1;i > 0;i --){
					if(c[i]!=0)
			break;
			}
		
			for(;i >= 0;i --)
				printf("%d",c[i]);
			printf("n");
		}
		if(j!=T)
		printf("n");
	}
return 0;
}

(编辑:核心网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    热点阅读