加入收藏 | 设为首页 | 会员中心 | 我要投稿 核心网 (https://www.hxwgxz.com/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

HDU 1212 Big Number(大数取模)

发布时间:2021-03-09 20:14:20 所属栏目:大数据 来源:网络整理
导读:Big Number Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 7063????Accepted Submission(s): 4866 Problem Description As we know,Big Number is always troublesome. But it's really impor

Big Number

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7063????Accepted Submission(s): 4866


Problem Description As we know,Big Number is always troublesome. But it's really important in our ACM. And today,your task is to write a program to calculate A mod B.

To make the problem easier,I promise that B will be smaller than 100000.

Is it too hard? No,I work it out in 10 minutes,and my program contains less than 25 lines.
?
Input The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000,and B will be smaller than 100000. Process to the end of file.
?
Output For each test case,you have to ouput the result of A mod B.
?
Sample Input
  
  
   
   2 3
12 7
152455856554521 3250
  
  
?
Sample Output
  
  
   
   2
5
1521
  
  
?
Author Ignatius.L ?
Source 杭电ACM省赛集训队选拔赛之热身赛 ?
Recommend Eddy???|???We have carefully selected several similar problems for you:?? 1215? 1211? 1210? 1214? 1002?

代码:
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    int mod(char n1[],int n)
    {
        int len=strlen(n1);
        int temp=0;
        for(int i=0;i<len;i++)
        {
            temp=temp*10+n1[i]-'0';
            temp=temp%n;
        }
        return temp;
    }
    int main()
    {
        char s[1000000];
        int num;
        while(~scanf("%s%d*c",&s,&num))
        {
            printf("%dn",mod(s,num));
        }
    }

(编辑:核心网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    热点阅读