加入收藏 | 设为首页 | 会员中心 | 我要投稿 核心网 (https://www.hxwgxz.com/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

POJ 1053 Integer Inquiry (大数加法,还是Java大法好)

发布时间:2021-03-14 21:06:08 所属栏目:大数据 来源:网络整理
导读:Integer Inquiry Time Limit: ?1000MS ? Memory Limit: ?10000K Total Submissions: ?32674 ? Accepted: ?12789 Description One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0

Integer Inquiry

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.?
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)?

Input

The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).?

The final input line will contain a single zero on a line by itself.?

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

Source

East Central North America 1996
原题链接:http://poj.org/problem?id=1503
PS:变形的大数加法,还是Java 好!

AC代码:

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			BigInteger sum = new BigInteger("0",10);
			BigInteger x = sc.nextBigInteger();
			if(x.equals(new BigInteger("0"))){//注意,与'0'判断时要new对象!!!
				System.out.println(sum);
				break;
			}
			sum = sum.add(x);
		}

	}

}

AC代码2;

#include <stdio.h>
#include <string.h>
char a[1000];
int sum[1000],data[1000];
int length_sum;
int main()
{
    int i,j,length_a,jin,temp;
    memset(sum,sizeof(sum));
    while(1)
    {
        scanf("%s",a);
        length_a=strlen(a);
        if (a[0]=='0'&&length_a==1)
        {
            length_sum=999;
            while(sum[length_sum]==0)
            {
                length_sum--;
            }
            for (i=length_sum; i>=0; i--)
            {
                printf("%d",sum[i]);
            }
            break;
        }
        else
        {
            memset(data,sizeof(data));
            for (j=0,i=length_a-1; i>=0; i--)
            {
                data[j++]=a[i]-'0';
            }
            for(jin=0,i=0; i<1000; i++)
            {
                temp=sum[i]+data[i]+jin;
                sum[i]=temp%10;
                jin=temp/10;
            }
        }
    }
    return 0;
}

(编辑:核心网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    热点阅读