加入收藏 | 设为首页 | 会员中心 | 我要投稿 核心网 (https://www.hxwgxz.com/)- 科技、建站、经验、云计算、5G、大数据,站长网!
当前位置: 首页 > 大数据 > 正文

hdoj 1002 A + B Problem II 大数

发布时间:2021-05-29 01:43:57 所属栏目:大数据 来源:网络整理
导读:A + B Problem II Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 302658????Accepted Submission(s): 58410 Problem Description I have a very simple problem for you. Given two integers

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)????Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 302658????Accepted Submission(s): 58410


Problem Description I have a very simple problem for you. Given two integers A and B,your job is to calculate the Sum of A + B.
?
Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow,each line consists of two positive integers,A and B. Notice that the integers are very large,that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
?
Output For each test case,you should output two lines. The first line is "Case #:",# means the number of the test case. The second line is the an equation "A + B = Sum",Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
?
Sample Input
  
  
   
   2
1 2
112233445566778899 998877665544332211
  
  
?
Sample Output
  
  
   
   Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 2222222222222221110
  
  
?
Author Ignatius.L ?
Recommend We have carefully selected several similar problems for you:?? 1004? 1003? 1008? 1009? 1020



import java.util.*;//输入的库
import java.math.*;//大数时用的库
import java.io.*;
public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
     Scanner in = new Scanner(System.in);
     BigInteger a;//大数标准定义格式
     BigInteger b;
     int n,i;
     n=in.nextInt();
     for(i=1;i<=n;i++)
     {
    	 a=in.nextBigInteger();
    	 b=in.nextBigInteger();
    	 System.out.println("Case "+i+":");
    	 System.out.println(a +" + "+b +" = "+a.add(b));
    	 if(i!=n)
    	 System.out.println();
    	 
    	 
     }
	}

}

(编辑:核心网)

【声明】本站内容均来自网络,其相关言论仅代表作者个人观点,不代表本站立场。若无意侵犯到您的权利,请及时与联系站长删除相关内容!

    热点阅读